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1 Introduction 
The Food Management portion of the system is where WIC-approved foods, participant 
profiles, food rules, and model food packages are maintained.  Each food must be entered in 
the system’s database before it can be selected to be included in a model food package.  
Once participant profiles are set up, the food packages and the USDA food rules work in 
conjunction with each other to validate food packages assigned to participants in the Clinic 
Services system area.    

The first section within Food Management is made up of the Food screens.  These screens 
support the USDA food structure and start with a screen to manage the food categories.  
The food structure hierarchy is designed to handle either type of food delivery states: paper 
FIs or EBT Cards.  Edits enforce the necessary business rules to ensure that each type is set 
up correctly.  The remaining screens are used to manage this hierarchy: Subcategories, 
Containers and UPC/PLU Detail Products. The Subcategory screen is used to create, update 
and display the subcategory and its primary attributes.  The Containers screen is used to 
create, update and display the containers of a subcategory with its primary attributes as 
well as its peer group pricing information.   The UPC Detail Products screen is used to 
create, update and display the detail products appropriately based on food delivery type.  
For paper FI based states, the detail products under the containers are primarily for price 
survey purposes to set the peer group pricing at the container level.  These detail products 
may be defined generically or with a specific UPC.  For EBT-based states, the detail products 
require UPCs and are under the subcategory/container level (1 to 1 relationship).  UPC 
detail products are tied to much more functionality in the EBT states (i.e. purchases) and 
require a screen for their peer group pricing. 

The second section within Food Management is the Manufacturer screens. The first screen, 
Contacts and Address, is used to record basic information about a manufacturer including 
the name, contact information and address information.  The next screen is used to record 
rebate information identifying the formulas and entering their corresponding effective date, 
end date, rate and group numbers.  This screen also allows the printing of the 
manufacturer’s rebate invoice. 

The third section within Food Management is the Participant Profiles screen. The participant 
profiles screen is used to associate the previously defined participant profiles to the food 
rules and the model food packages. 

The fourth section within Food Management is the WIC Formula Levels screen. The WIC 
Formula Level screen is used to determine a breastfeeding woman’s participant profile 
attribute based on the amount of formula that her infant is receiving from WIC. 

The fifth section with Food Management is comprised of the Food Rules screens.   The first 
screen, Foods, is used to add, modify, and delete product rules for each food subcategory.  
These rules define the maximum amount of each product a WIC participant receives based 
on the USDA maximums or state-specific maximum.  The specific items associated with 
each subcategory are then defined on the Food Rules screen.  A Calculate Nutritional 
equivalent pop-up is provided to aid the user in determining the nutritional equivalent of 
one food item to another.  The second screen, Participant Profiles, is used to associate 
previously defined participant profiles to the food rules.   

The sixth section within Food Management is the Change Food Rule screen.  This screen is 
used to define changes that are automatically applied when a participant reaches a 
milestone. 
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The seventh section within Food Management is the Model Food Packages screens. This 
section is used to add, edit, or delete a model food package.  Model food packages are set 
up by the state WIC office and are generally the most commonly issued food packages.  The 
first screen, Model Food Package, is used to enter the food item, quantity and months.  The 
second screen, Package Participant Profiles, is used to associate the model food packages 
with the participant profiles previously set up in the system. These associations are what 
provide validation when issuing a food package to a participant in the clinic services module 
of the system.   

The last section is the Verification Results screen which is used to display any rule violations 
from the verification process.  In order for a model food package to be used in Clinic 
Services it must completely pass the verification process, which takes into account all of the 
food rules and participant profiles defined previously. 
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2 Navigation Panel 
The Navigation Panel contains the Navigation Buttons (stacked starting from the bottom of 
panel) and the Navigation Tree Structure (top of panel). 

2.1 Navigation Button 
The Navigation Button labeled “Food Management” will allow the user to access the 
operation screens. 

When the user clicks on the Food Management Navigation Button, 

• Navigation Panel will contain the food management tree structure with the branch 
nodes collapsed.  See the Navigation Tree Structure section in this document for 
more details. 

• Main Panel contains the System Brand Screen.  See the System Overview DFDD for 
more details on the System Brand Screen. 

• Information Panel displays the System tab by default. 

2.2 Navigation Tree Structure 
The Navigation Tree Structure for the Food Management area contains the functions that 
are described in the accompanying functional DFDDs.  A user’s view will differ based on 
their security access profile. 

2.2.1 Connected Mode 
This tree structure shows the maximum possibilities for this functional area for a user in 
connected mode. 
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Note: UPC/PLU Detail Products is only available in EBT states. 

2.2.2 Disconnected Mode 
There is no functionality available in this functional area for a user in disconnected mode. 

2.3 Saving Work 
The Food Management saves units of work at the following levels: 

• Foods 

• Manufacturers 

• Participant Profiles 

• WIC Formula Level 

• Food Rules 

• Change Food Rule 

• Model Food Packages 
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3 Main Panel 
This panel is where all the screens described in the accompanying DFDDs are displayed. 

When the user clicks on the Food Management Navigation Button, the System Brand screen 
is displayed in the main panel. 
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4 Information Panel 
The Information Panel contains two tabs. The first will be entitled “System” which contains 
active “System Wide” and “Food Management” type system messages.  The second will be 
entitled “Messages” which will contain warning and error messages associated with the main 
panel screen. These are described in the System Overview DFDD. 
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5 Menu Bar 
The Food Management Menu Bar is visible at all times and is found at the top of the screen. 

 

Control Description 

File Select File to display File menu options. See the File Menu 
section for more information. 

 Type Menu Item 

 Hot Key Alt + F 

Edit Select Edit to display Edit menu options. See the Edit Menu 
section for more information. 

 Type  Menu Item  

 Hot Key Alt + E 

Help Select Help to display Help menu options. See the Help Menu 
section for more information. 

 Type  Menu Item 

 Hot Key Alt + H 

5.1 File Menu 
The File menu is visible at all times, giving access to common File functions.  

 

Control Description 

Save Select Save to save the unit of work. 

 Type Menu Item 

 Hot Key Ctrl + S 

Change Clinic Select Change Clinic to select a different clinic. 

 Type Menu Item 

 Hot Key Ctrl + G 

Exit Select Exit to exit the application. 

 Type Menu Item 

 Hot Key Alt + F4 
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5.1.1 Change Clinic 
This pop-up is used to change the clinic that the user is logged into.   At user login, the user 
selects a clinic.  The access for the user is based on the clinic.   

 

Control Description 

unlabeled The unlabeled data grid within the Change Clinic pop-up allows 
the user to select another clinic.  The user sees clinics that they 
have access rights to see.  The user highlights the clinic that 
they want to go to and clicks the OK button. 

 Type Read-Only Data Grid 

LA-Clinic number This is the local agency-clinic number. 

 Format Z9-ZZZZ9 Calculated No 

Clinic name This is the name of the clinic. 

 Format Alphanumeric Calculated No 

OK Clicking the OK button changes the clinic and returns the user 
back to the main application. 

 Type Command Button 

 Hot Key Alt + O 

Cancel Clicking the Cancel button returns the user back to the main 
application. 

 Type Command Button 

 Hot Key Alt + L 
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5.2 Edit Menu 
The Edit menu is visible at all times, giving access to editing functions.  Most editing is done 
on the individual screen.   

 

 

 

Control Description 

Cut Select the Cut menu item to remove selected text to paste it to 
another location. 

 Type Menu Item 

 Hot Key Ctrl + X 

Copy Select the Copy menu item to create a copy of selected text to 
paste it to another location. 

 Type Menu Item 

 Hot Key Ctrl + C 

Paste Select the Paste menu item to place text cut or copied in the 
selected location. 

 Type Menu Item 

 Hot Key Ctrl + V 

5.3 Help Menu 
The Help menu is visible at all times, giving access to user help and system version 
information. 

 

Control Description 

User Help Clicking the User Help menu item allows the user to view the 
current version of the application User Help.  This opens a Help 
Window as described in the System Overview DFDD. 

 Type Menu Item 

 Hot Key None 
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Control Description 

About (System Name) Clicking the About (parameter) menu item allows the user to 
view version and system information. 

 Type Menu Item 

 Hot Key None 

5.3.1 About (System Name) Pop-up 
This pop-up provides the user with the version number of the application and allows for 
assemblies to be viewed as needed. 

 

  

 

Control Description 

Version The version number that is displayed shows the version of the 
application that is currently being used (as defined in system 
parameter). 

 Type Text Box 

 Required NA 

 Length NA 

 Validation NA 

 Display Only Yes Calculated No 

 DB Column Not Stored 
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Control Description 

 

The CIBER logo appears for branding purposes.  This is the 
company that developed the application. 

 Type Text Box 

 Required Yes 

 Length NA 

 Validation NA 

 Display Only Yes Calculated No 

 DB Column NA 

Show Assemblies/Hide 
Assemblies 

By default, the About (System Name) Pop-Up displays the 
version number of the application.  Clicking the Show Assemblies 
command button displays system assemblies.  Clicking the Hide 
Assemblies command button returns to the default view. 

 Type Command Button 

 Hot Key Alt + M 

Close Clicking the Close command button closes the About (system 
name) pop-up and returns the user to the Clinic Services 
screens. 

 Type Command Button 

 Hot Key Alt + C 

 
Business Rules 

1.  

 
Developer Notes 

1.  

 



MPSC WIC Data System Project FM 0 Food Management Overview 

6 Tool Bar 
The Food Management Tool Bar is visible at all times, giving access to frequently used 
functions and screens. 

 

Control Description 

 Clicking this icon saves any changes that were made on the 
current screen to the database. 

 Type Command Button 

 Hot Key None 
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